Posted on

Do You need Kodi 17.3 Krypton to Patch Major Security Flaw?

You guys may have seen the news that recommend you update Kodi to 17.3 for security reasons.

First to ease you all iOS and Apple TV users, the flaw will not hack your device, you have nothing to worry about your Apple TV device, because KODI on Apple TV is running in a Safe Sandbox, so it will not doing anything dangerous to your system.

Unfortunately Kodi 17.3 is not released yet for Apple TV, we are watching closely to the official Kodi developer team, will push the update to our customers as soon as it’s available to download.
You can also check the latest Kodi for Apple TV version here: http://mirrors.kodi.tv/test-builds/darwin/

Our iPhone and iPad customers can now update to 17.3 by visiting this URL on your device:
koditvbox.ca/install/ios.php

As of the so called security flaw, what is it exactly, how to prevent getting hacked?

Earlier this week, a security flaw within Kodi (and other media players including VLC) was reported by researchers from Check Point Software Technologies. They demonstrated that an attacker could gain control of any Kodi device through the use of malicious code placed within subtitles. Hypothetically, if an infected subtitle file were to be downloaded by Kodi, it could give a hacker full control over your device. This is particularly concerning when it comes to automatically downloaded subtitles.

So just be on safe side, for now, you should stop automatic Subtitle download, and only get it from trusted sources.

Below is the demo video (shot on Windows PC, not any Apple Devices)